Главная » 2017 » Февраль » 20 » Домашнее задание для 8Б на 27 февраля
11:32
Домашнее задание для 8Б на 27 февраля

Домашнее задание для 8Б на 27 февраля

Решить задачи (ссылка на задачи):

  1. Определите значение переменной b после выполнения данного алгоритма:

a := 7

b := 4

a := 5 * b – 2 * a

b := a / 3 * 8 + 5 * b

  1. Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведен на трех языках программирования.

алг

нач

  цел s,k

  s:=0

  нц для k от 3 до 9

    s:=s+9

  кц

  вывод s

кон

  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды:

Вперед n (где n- целое число), вызывающая передвижение Черепашки на n шагов в направлении движения;

Направо m (где m- целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Черепашке был дан для исполнения следующий алгоритм:

Повтори 9 [Вперед 20 Направо 60 Вперед 20]

Какая фигура появится на экране?

 

  1. В таблице Dat хранятся отметки учащихся 9 класса за самостоятельную работу (Dat[1] – отметка первого учащегося). Определите, какое число будет напечатано в результате работы следующей программы.

алг

нач

 целтаб Dat[1:10]

 цел k, m

 Dat[1] := 4

 Dat[2] := 5

 Dat[3] := 4

 Dat[4] := 3

 Dat[5] := 2

 Dat[6] := 3

 Dat[7] := 4

 Dat[8] := 5

 Dat[9] := 5

 Dat[10] := 3

m := 0

нц для k от 1 до 10

   если Dat[k] < 4 то

   m := m + Dat[k]

  все

кц

вывод m

     кон

 

  1. У исполнителя Вычислитель две команды, которым присвоены номера:
  1. Умножь на 4
  2. Вычти 1

Составьте алгоритм получения из числа 3 числа 39, содержащей не более 5 команд. В ответе запишите только номера команд.

Просмотров: 245 | Добавил: Olesya-school1 | Рейтинг: 0.0/0
Всего комментариев: 0
Имя *:
Email *:
Код *: